Investigating issues related to Google Cloud authentication

Incident Report for Photoroom API

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 21:21 UTC

Monitoring

Authentication issues have been identified due to a Google Cloud outage. We're monitoring the situation closely and will update this as we move towards a resolution.
Posted Jun 12, 2025 - 18:34 UTC